No puedo actualizar plugins y themes desde el panel de WordPress

Si usas Vesta como panel de control y no has creado las webs desde Vesta es posible que no tengas problemas para actualizar plugins y themes desde el panel de control de WordPress.

El problema viene si has subido WordPress directamente por FTP con el usuario root, en cuando intentes actualizar plugins y themes WordPress te mostrará un mensaje rojo:

«Error en la actualización: No ha sido posible instalar la actualización debido a que no se han podido copiar algunos archivos»

Para solucionar esto tendrás que entrar en el servidor con un cliente SSH, primero tendrás que situarte en la carpeta donde tienes las webs por ejemplo:

cd /home/admin/web/dominio.com

Y luego ejecutar la siguiente línea para dar permisos al usuario admin de forma recursiva en todos los ficheros, carpetas y subcarpetas:

chown -R admin public_html/

Si intentas ahora actualizar los plugins y themes desde el panel de wordpress ya no deberías tener problemas, se acabó eso de subir y actualizar plugins a pelo.

No puedo actualizar plugins y themes desde el panel de WordPress
Valorar

Dejar un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.plugin cookies

ACEPTAR
Aviso de cookies